CVE-2026-23480
Blinko is an AI-powered card note-taking project. Prior to version 1.8.4, there is a privilege escalation vulnerability. The upsertUser endpoint has 3 issues: it is missing superAdminAuthMiddleware, any logged-in user can call it; the originalPassword is an optional parameter and if not provided password verification is skipped; there is no check for input.id === ctx.id (ownership verification). This could result in any authenticated user modifying other users' passwords, direct escalation to superadmin, and complete account takeover. This issue has been patched in version 1.8.4.
- Score
- CVSS 3.1 8.8 High
- Status
- Analyzed - security-advisories@github.com
- Published
- 2026-03-23
- Last modified
- 2026-03-24
- Weaknesses
- CWE-288
Affected products
References
- https://github.com/blinkospace/blinko/commit/3afbdf486b6f371bdac5781dea6289749f2c4c03
- https://github.com/blinkospace/blinko/releases/tag/1.8.4
- https://github.com/blinkospace/blinko/security/advisories/GHSA-r3mv-q7ww-86p6