CVE-2026-103552
Stack Overflow vulnerability in Apache Directory LDAP API. Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder. This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9. Users are recommended to upgrade to version 1.2.9, which fixes the issue.
- Score
- CVSS 3.1 7.3 High
- Status
- Deferred - security@apache.org
- Published
- 2026-10-02
- Last modified
- 2026-10-02
- Weaknesses
- CWE-121
Affected products
References
- https://lists.apache.org/thread.html/fn3bwknn57266hx66w9vv6b4k8rfwcx7
- http://www.openwall.com/lists/oss-security/2026/10/02/4