CVE-2025-71404

better-auth versions after v0.0.2 and before 1.1.16 contain a reflected cross-site scripting (XSS) vulnerability on the /api/auth/error page, where the value of the 'error' URL parameter is reflected as HTML without proper neutralization. An attacker who coerces a user into visiting a specially-crafted URL can execute arbitrary JavaScript in the context of the user's browser. The issue is fixed in version 1.1.16.

Score
CVSS 4.0 5.1 Medium
Status
Deferred - disclosure@vulncheck.com
Published
2026-08-01
Last modified
2026-10-06
Weaknesses
CWE-79

Affected products

References