CVE-2025-66516
Critical XXE in Apache Tika tika-core (1.13-3.2.1), tika-pdf-module (2.0.0-3.2.1) and tika-parsers (1.13-1.28.5) modules on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. This CVE covers the same vulnerability as in CVE-2025-54988. However, this CVE expands the scope of affected packages in two ways. First, while the entrypoint for the vulnerability was the tika-parser-pdf-module as reported in CVE-2025-54988, the vulnerability and its fix were in tika-core. Users who upgraded the tika-parser-pdf-module but did not upgrade tika-core to >= 3.2.2 would still be vulnerable. Second, the original report failed to mention that in the 1.x Tika releases, the PDFParser was in the "org.apache.tika:tika-parsers" module.
- Score
- CVSS 3.1 9.8 Critical
- Status
- Modified - security@apache.org
- Published
- 2025-12-04
- Last modified
- 2026-02-26
- Weaknesses
- CWE-611
Affected products
- Tika (Apache)
- Apache Tika Core (Apache Software Foundation)
- Apache Tika Parsers (Apache Software Foundation)
- Apache Tika Pdf Parser Module (Apache Software Foundation)
References
- https://cve.org/CVERecord?id=CVE-2025-54988
- https://lists.apache.org/thread/s5x3k93nhbkqzztp1olxotoyjpdlps9k