CVE-2025-66172
The CloudStack Backup plugin has an improper access logic in versions 4.21.0.0 and 4.22.0.0. Anyone with authenticated user-account access in CloudStack 4.21.0.0+ environments, where this plugin is enabled and have access to specific APIs can restore a volume from any other user's backups and attach the volume to their own VMs. Backup plugin users using CloudStack 4.21.0.0+ are recommended to upgrade to CloudStack version 4.22.0.1, which fixes this issue.
- Score
- CVSS 3.1 8.1 High
- Status
- Analyzed - security@apache.org
- Published
- 2026-05-08
- Last modified
- 2026-10-07
- Weaknesses
- CWE-359
Affected products
References
- https://lists.apache.org/thread/n8mt5b7wkpysstb8w7rr9f02kc5cq2xm
- http://www.openwall.com/lists/oss-security/2026/05/09/3