CVE-2025-66170

The CloudStack Backup plugin has an improper authorization logic in versions 4.21.0.0 and 4.22.0.0. Anyone with authenticated user-account access in CloudStack 4.21.0.0+ environments, where this plugin is enabled and has access to specific APIs can list backups from any account in the environment. This vulnerability does not allow them to see the contents of the backup. Users are recommended to upgrade to version 4.22.0.1, which fixes the issue.

Score
CVSS 3.1 6.5 Medium
Status
Analyzed - security@apache.org
Published
2026-05-08
Last modified
2026-10-07
Weaknesses
CWE-863

Affected products

References