CVE-2025-64110
Cursor is a code editor built for programming with AI. In versions 1.7.23 and below, a logic bug allows a malicious agent to read sensitive files that should be protected via cursorignore. An attacker who has already achieved prompt injection, or a malicious model, could create a new cursorignore file which can invalidate the configuration of pre-existing ones. This could allow a malicious agent to read protected files. This issue is fixed in version 2.0.
- Score
- CVSS 4.0 8.7 High
- Status
- Analyzed - security-advisories@github.com
- Published
- 2025-11-05
- Last modified
- 2026-10-19
- Weaknesses
- CWE-284
Affected products
References
- https://github.com/cursor/cursor/security/advisories/GHSA-vhc2-fjv4-wqch