CVE-2025-62372

vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, users can crash the vLLM engine serving multimodal models by passing multimodal embedding inputs with correct ndim but incorrect shape (e.g. hidden dimension is wrong), regardless of whether the model is intended to support such inputs (as defined in the Supported Models page). This issue has been patched in version 0.11.1.

Score
CVSS 4.0 8.3 High
Status
Analyzed - security-advisories@github.com
Published
2025-11-21
Last modified
2026-10-19
Weaknesses
CWE-129

Affected products

References