CVE-2025-59059
Remote Code Execution Vulnerability in NashornScriptEngineCreator is reported in Apache Ranger versions <= 2.7.0. Users are recommended to upgrade to version 2.8.0, which fixes this issue.
- Score
- CVSS 3.1 9.8 Critical
- Status
- Analyzed - security@apache.org
- Published
- 2026-03-03
- Last modified
- 2026-03-03
- Weaknesses
- CWE-94
Affected products
References
- https://lists.apache.org/thread/z47q86rho80390lf2qcmoc2josvs0gtv
- http://www.openwall.com/lists/oss-security/2026/03/02/5