CVE-2025-58098
Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd="..." directives. This issue affects Apache HTTP Server before 2.4.66. Users are recommended to upgrade to version 2.4.66, which fixes the issue.
- Score
- CVSS 3.1 8.3 High
- Status
- Analyzed - security@apache.org
- Published
- 2025-12-05
- Last modified
- 2026-02-26
- Weaknesses
- CWE-201
Affected products
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- http://www.openwall.com/lists/oss-security/2025/12/04/5