CVE-2025-57773
DataEase is an open source business intelligence and data visualization tool. Prior to version 2.10.12, because DB2 parameters are not filtered, a JNDI injection attack can be directly launched. JNDI triggers an AspectJWeaver deserialization attack, writing to various files. This vulnerability requires commons-collections 4.x and aspectjweaver-1.9.22.jar. The vulnerability has been fixed in version 2.10.12.
- Score
- CVSS 3.1 9.8 Critical
- Status
- Analyzed - security-advisories@github.com
- Published
- 2025-08-25
- Last modified
- 2025-08-25
- Weaknesses
- CWE-502, CWE-94
Affected products
References
- https://github.com/dataease/dataease/commit/8d04e92d44e1bac9284e9e64df5afd7f96d9373c
- https://github.com/dataease/dataease/security/advisories/GHSA-7r8j-6whv-4j5p