CVE-2025-55675
Apache Superset contains an improper access control vulnerability in its /explore endpoint. A missing authorization check allows an authenticated user to discover metadata about datasources they do not have permission to access. By iterating through the datasource_id in the URL, an attacker can enumerate and confirm the existence and names of protected datasources, leading to sensitive information disclosure. This issue affects Apache Superset: before 5.0.0. Users are recommended to upgrade to version 5.0.0, which fixes the issue.
- Score
- CVSS 3.1 6.5 Medium
- Status
- Modified - security@apache.org
- Published
- 2025-08-14
- Last modified
- 2025-11-04
- Weaknesses
- CWE-285
Affected products
References
- https://lists.apache.org/thread/op681b4kbd7g84tfjf9omz0sxggbcv33
- http://www.openwall.com/lists/oss-security/2025/08/14/6