CVE-2025-55283
aiven-db-migrate is an Aiven database migration tool. Prior to 1.0.7, there is a privilege escalation vulnerability that allows elevation to superuser inside PostgreSQL databases during a migration from an untrusted source server. The vulnerability stems from psql executing commands embedded in a dump from the source server. This vulnerability is fixed in 1.0.7.
- Score
- CVSS 3.1 9.1 Critical
- Status
- Analyzed - security-advisories@github.com
- Published
- 2025-08-18
- Last modified
- 2025-08-18
- Weaknesses
- CWE-77
Affected products
References
- https://github.com/aiven/aiven-db-migrate/commit/36f6c7f7d06216975f625da0a1cb514253c4b3df
- https://github.com/aiven/aiven-db-migrate/security/advisories/GHSA-wqhc-grmj-fjvg