CVE-2025-54988
Critical XXE in Apache Tika (tika-parser-pdf-module) in Apache Tika 1.13 through and including 3.2.1 on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. An attacker may be able to read sensitive data or trigger malicious requests to internal resources or third-party servers. Note that the tika-parser-pdf-module is used as a dependency in several Tika packages including at least: tika-parsers-standard-modules, tika-parsers-standard-package, tika-app, tika-grpc and tika-server-standard. Users are recommended to upgrade to version 3.2.2, which fixes this issue.
- Score
- CVSS 3.1 9.8 Critical
- Status
- Modified - security@apache.org
- Published
- 2025-08-20
- Last modified
- 2026-02-26
- Weaknesses
- CWE-611
Affected products
References
- https://lists.apache.org/thread/8xn3rqy6kz5b3l1t83kcofkw0w4mmj1w
- http://www.openwall.com/lists/oss-security/2025/08/20/2
- http://www.openwall.com/lists/oss-security/2025/08/20/3
- https://lists.debian.org/debian-lts-announce/2025/10/msg00030.html