CVE-2025-48977
Relative Path Traversal vulnerability in Apache Ignite REST API. Authenticated REST API users can read any file on the server with "cmd=log" command and a log path crafted in a certain way. This issue affects Apache Ignite: from 2.0.0 through 2.17.0. Users are recommended to upgrade to version 2.18.0, which fixes the issue.
- Score
- CVSS 4.0 8.5 High
- Status
- Analyzed - security@apache.org
- Published
- 2026-05-28
- Last modified
- 2026-10-07
- Weaknesses
- CWE-23
Affected products
References
- https://lists.apache.org/thread/hgct6918sowd8l58yjohryhpxx81t4n1
- http://www.openwall.com/lists/oss-security/2026/05/28/3