CVE-2025-48877
Discourse is an open-source discussion platform. Prior to version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch, Codepen is present in the default `allowed_iframes` site setting, and it can potentially auto-run arbitrary JS in the iframe scope, which is unintended. This issue is patched in version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch. As a workaround, the Codepen prefix can be removed from a site's `allowed_iframes`.
- Score
- CVSS 3.1 9.8 Critical
- Status
- Analyzed - security-advisories@github.com
- Published
- 2025-06-09
- Last modified
- 2025-06-09
- Weaknesses
- CWE-1038
Affected products
References
- https://github.com/discourse/discourse/security/advisories/GHSA-cm93-6m2m-cjcv