CVE-2025-46701
Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue.
- Score
- CVSS 3.1 7.3 High
- Status
- Modified - security@apache.org
- Published
- 2025-05-29
- Last modified
- 2025-11-03
- Weaknesses
- CWE-178
Affected products
References
- https://lists.apache.org/thread/xhqqk9w5q45srcdqhogdk04lhdscv30j
- http://www.openwall.com/lists/oss-security/2025/05/29/4
- https://lists.debian.org/debian-lts-announce/2025/07/msg00009.html