CVE-2025-46338
Audiobookshelf is a self-hosted audiobook and podcast server. Prior to version 2.21.0, an improper input handling vulnerability in the `/api/upload` endpoint allows an attacker to perform a reflected cross-site scripting (XSS) attack by submitting malicious payloads in the `libraryId` field. The unsanitized input is reflected in the server’s error message, enabling arbitrary JavaScript execution in a victim's browser. This issue has been patched in version 2.21.0.
- Score
- CVSS 4.0 6.9 Medium
- Status
- Analyzed - security-advisories@github.com
- Published
- 2025-04-29
- Last modified
- 2025-04-29
- Weaknesses
- CWE-79
Affected products
References
- https://github.com/advplyr/audiobookshelf/commit/35870a01583b2947030f4e3d4ac769c3ff298386
- https://github.com/advplyr/audiobookshelf/security/advisories/GHSA-47g3-c5hx-2q3w