CVE-2025-30067

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Kylin. If an attacker gets access to Kylin's system or project admin permission, the JDBC connection configuration maybe altered to execute arbitrary code from the remote. You are fine as long as the Kylin's system and project admin access is well protected. This issue affects Apache Kylin: from 4.0.0 through 5.0.1. Users are recommended to upgrade to version 5.0.2 or above, which fixes the issue.

Score
CVSS 3.1 7.2 High
Status
Analyzed - security@apache.org
Published
2025-03-27
Last modified
2025-03-27
Weaknesses
CWE-94

Affected products

References