CVE-2025-27821

Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client. This issue affects Apache Hadoop: from 3.2.0 before 3.4.2. Users are recommended to upgrade to version 3.4.2, which fixes the issue.

Score
CVSS 3.1 7.3 High
Status
Analyzed - security@apache.org
Published
2026-01-26
Last modified
2026-01-26
Weaknesses
CWE-787

Affected products

References