CVE-2025-27446
Incorrect Permission Assignment for Critical Resource vulnerability in Apache APISIX(java-plugin-runner). Local listening file permissions in APISIX plugin runner allow a local attacker to elevate privileges. This issue affects Apache APISIX(java-plugin-runner): from 0.2.0 through 0.5.0. Users are recommended to upgrade to version 0.6.0 or higher, which fixes the issue.
- Score
- CVSS 3.1 7.8 High
- Status
- Modified - security@apache.org
- Published
- 2025-07-06
- Last modified
- 2026-02-26
- Weaknesses
- CWE-732
Affected products
References
- https://lists.apache.org/thread/qwxnxolt0j5nvjfpr0mlz6h7nrtvyzng
- http://www.openwall.com/lists/oss-security/2025/07/06/1
- http://www.openwall.com/lists/oss-security/2025/07/07/1