CVE-2025-14795
The Stop Spammers Classic plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2026.1. This is due to missing nonce validation in the ss_addtoallowlist class. This makes it possible for unauthenticated attackers to add arbitrary email addresses to the spam allowlist via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. The vulnerability was partially patched in version 2026.1.
- Score
- CVSS 3.1 4.3 Medium
- Status
- Deferred - security@wordfence.com
- Published
- 2026-01-28
- Last modified
- 2026-04-08
- Weaknesses
- CWE-352
Affected products
References
- https://plugins.trac.wordpress.org/browser/stop-spammer-registrations-plugin/tags/2025.4/classes/ss_addtoallowlist.php#…
- https://plugins.trac.wordpress.org/changeset/3436357/
- https://plugins.trac.wordpress.org/changeset/3440788/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5d6f38d7-a769-422d-ae3f-565cb1cc8a73?source=cve