CVE-2025-0182
A vulnerability in danswer-ai/danswer version 0.9.0 allows for denial of service through memory exhaustion. The issue arises from the use of a vulnerable version of the starlette package (<=0.49) via fastapi, which was patched in fastapi version 0.115.3. The vulnerability can be exploited by sending multiple requests to the /auth/saml/callback endpoint, leading to uncontrolled memory consumption and eventual denial of service.
- Score
- CVSS 3.0 7.5 High
- Status
- Deferred - security@huntr.dev
- Published
- 2025-03-20
- Last modified
- 2025-10-15
- Weaknesses
- CWE-770
Affected products
References
- https://huntr.com/bounties/969b8056-b66c-4d70-8f77-04c1cbdc1d1a