CVE-2024-54677
Uncontrolled Resource Consumption vulnerability in the examples web application provided with Apache Tomcat leads to denial of service. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.1, from 10.1.0-M1 through 10.1.33, from 9.0.0.M1 through 9.9.97. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.2, 10.1.34 or 9.0.98, which fixes the issue.
- Score
- CVSS 3.1 5.3 Medium
- Status
- Modified - security@apache.org
- Published
- 2024-12-17
- Last modified
- 2025-11-03
- Weaknesses
- CWE-400
Affected products
References
- https://lists.apache.org/thread/tdtbbxpg5trdwc2wnopcth9ccvdftq2n
- http://www.openwall.com/lists/oss-security/2024/12/17/5
- http://www.openwall.com/lists/oss-security/2024/12/17/6
- http://www.openwall.com/lists/oss-security/2024/12/18/1
- https://lists.debian.org/debian-lts-announce/2025/07/msg00009.html
- https://security.netapp.com/advisory/ntap-20250131-0006/