CVE-2024-53947
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Superset. Specifically, certain engine-specific functions are not checked, which allows attackers to bypass Apache Superset's SQL authorization. This issue is a follow-up to CVE-2024-39887 with additional disallowed PostgreSQL functions now included: query_to_xml_and_xmlschema, table_to_xml, table_to_xml_and_xmlschema. This issue affects Apache Superset: <4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue or add these Postgres functions to the config set DISALLOWED_SQL_FUNCTIONS.
- Score
- CVSS 3.1 9.8 Critical
- Status
- Analyzed - security@apache.org
- Published
- 2024-12-09
- Last modified
- 2024-12-09
- Weaknesses
- CWE-89
Affected products
References
- https://lists.apache.org/thread/hj3gfsjh67vqw12nlrshlsym4bkopjmn