CVE-2024-53679

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache VCL in the User Lookup form. A user with sufficient rights to be able to view this part of the site can craft a URL or be tricked in to clicking a URL that will give a specified user elevated rights. This issue affects all versions of Apache VCL through 2.5.1. Users are recommended to upgrade to version 2.5.2, which fixes the issue.

Score
CVSS 4.0 8.4 High
Status
Analyzed - security@apache.org
Published
2025-03-25
Last modified
2025-03-31
Weaknesses
CWE-79

Affected products

References