CVE-2024-52279

Improper Input Validation vulnerability in Apache Zeppelin. The fix for JDBC URL validation in CVE-2024-31864 did not account for URL encoded input. This issue affects Apache Zeppelin: from 0.11.1 before 0.12.0. Users are recommended to upgrade to version 0.12.0, which fixes the issue.

Score
CVSS 3.1 7.5 High
Status
Modified - security@apache.org
Published
2025-08-03
Last modified
2025-11-04
Weaknesses
CWE-20

Affected products

References