CVE-2024-52012
Relative Path Traversal vulnerability in Apache Solr. Solr instances running on Windows are vulnerable to arbitrary filepath write-access, due to a lack of input-sanitation in the "configset upload" API. Commonly known as a "zipslip", maliciously constructed ZIP files can use relative filepaths to write data to unanticipated parts of the filesystem. This issue affects Apache Solr: from 6.6 through 9.7.0. Users are recommended to upgrade to version 9.8.0, which fixes the issue. Users unable to upgrade may also safely prevent the issue by using Solr's "Rule-Based Authentication Plugin" to restrict access to the configset upload API, so that it can only be accessed by a trusted set of administrators/users.
- Score
- CVSS 3.1 5.4 Medium
- Status
- Analyzed - security@apache.org
- Published
- 2025-01-27
- Last modified
- 2025-02-06
- Weaknesses
- CWE-23
Affected products
References
- https://lists.apache.org/thread/yp39pgbv4vf1746pf5yblz84lv30vfxd
- http://www.openwall.com/lists/oss-security/2025/01/26/2