CVE-2024-47249
Improper Validation of Array Index vulnerability in Apache NimBLE. Lack of input validation for HCI events from controller could result in out-of-bound memory corruption and crash. This issue requires broken or bogus Bluetooth controller and thus severity is considered low. This issue affects Apache NimBLE: through 1.7.0. Users are recommended to upgrade to version 1.8.0, which fixes the issue.
- Score
- CVSS 3.1 5.0 Medium
- Status
- Analyzed - security@apache.org
- Published
- 2024-11-26
- Last modified
- 2024-12-06
- Weaknesses
- CWE-129
Affected products
References
- https://github.com/apache/mynewt-nimble/commit/f39330866a85fa4de49246e9d21334bc8d14f0a1
- https://lists.apache.org/thread/7ckxw6481dp68ons627pjcb27c75n0mq
- http://www.openwall.com/lists/oss-security/2024/11/26/3