CVE-2024-47248

Buffer Copy without Checking Size of Input ('Classic Buffer Overflow') vulnerability in Apache NimBLE. Specially crafted MESH message could result in memory corruption when non-default build configuration is used. This issue affects Apache NimBLE: through 1.7.0. Users are recommended to upgrade to version 1.8.0, which fixes the issue.

Score
CVSS 3.1 6.3 Medium
Status
Analyzed - security@apache.org
Published
2024-11-26
Last modified
2024-12-06
Weaknesses
CWE-120

Affected products

References