CVE-2024-46544
Incorrect Default Permissions vulnerability in Apache Tomcat Connectors allows local users to view and modify shared memory containing mod_jk configuration which may lead to information disclosure and/or denial of service. This issue affects Apache Tomcat Connectors: from 1.2.9-beta through 1.2.49. Only mod_jk on Unix like systems is affected. Neither the ISAPI redirector nor mod_jk on Windows is affected. Users are recommended to upgrade to version 1.2.50, which fixes the issue.
- Score
- CVSS 3.1 5.9 Medium
- Status
- Analyzed - security@apache.org
- Published
- 2024-09-23
- Last modified
- 2024-10-31
- Weaknesses
- CWE-276
Affected products
- Tomcat Connectors (Apache)
- Apache Tomcat Connectors (Apache Software Foundation)
- Debian Linux (Debian)
References
- https://lists.apache.org/thread/q1gp7cc38hs1r8gj8gfnopwznd5fpr4d
- http://www.openwall.com/lists/oss-security/2024/09/23/1
- https://lists.debian.org/debian-lts-announce/2024/10/msg00010.html