CVE-2024-45034

Apache Airflow versions before 2.10.1 have a vulnerability that allows DAG authors to add local settings to the DAG folder and get it executed by the scheduler, where the scheduler is not supposed to execute code submitted by the DAG author. Users are advised to upgrade to version 2.10.1 or later, which has fixed the vulnerability.

Score
CVSS 3.1 8.8 High
Status
Analyzed - security@apache.org
Published
2024-09-07
Last modified
2024-09-09
Weaknesses
CWE-250

Affected products

References