CVE-2024-41937

Apache Airflow, versions before 2.10.0, have a vulnerability that allows the developer of a malicious provider to execute a cross-site scripting attack when clicking on a provider documentation link. This would require the provider to be installed on the web server and the user to click the provider link. Users should upgrade to 2.10.0 or later, which fixes this vulnerability.

Score
CVSS 3.1 6.1 Medium
Status
Modified - security@apache.org
Published
2024-08-21
Last modified
2025-03-20
Weaknesses
CWE-79

Affected products

References