CVE-2024-41177
Incomplete Blacklist to Cross-Site Scripting vulnerability in Apache Zeppelin. This issue affects Apache Zeppelin: before 0.12.0. Users are recommended to upgrade to version 0.12.0, which fixes the issue.
- Score
- CVSS 3.1 6.1 Medium
- Status
- Modified - security@apache.org
- Published
- 2025-08-03
- Last modified
- 2025-11-04
- Weaknesses
- CWE-79
Affected products
References
- https://github.com/apache/zeppelin/pull/4755
- https://github.com/apache/zeppelin/pull/4795
- https://lists.apache.org/thread/nwh8vh9f3pnvt04n8z4g2kbddh62blr6
- http://www.openwall.com/lists/oss-security/2025/08/03/4