CVE-2024-39573

Potential SSRF in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows an attacker to cause unsafe RewriteRules to unexpectedly setup URL's to be handled by mod_proxy. Users are recommended to upgrade to version 2.4.60, which fixes this issue.

Score
CVSS 3.1 7.5 High
Status
Modified - security@apache.org
Published
2024-07-01
Last modified
2025-11-03
Weaknesses
CWE-20

Affected products

References