CVE-2024-35164

The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers via text-based protocols like SSH. If a malicious user has access to a text-based connection, a specially-crafted sequence of console codes could allow arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.6.0, which fixes this issue.

Score
CVSS 3.1 7.5 High
Status
Modified - security@apache.org
Published
2025-07-02
Last modified
2026-02-26
Weaknesses
CWE-129

Affected products

References