CVE-2024-32638
Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in Apache APISIX when using `forward-auth` plugin.This issue affects Apache APISIX: from 3.8.0, 3.9.0. Users are recommended to upgrade to version 3.8.1, 3.9.1 or higher, which fixes the issue.
- Score
- CVSS 3.1 6.3 Medium
- Status
- Analyzed - security@apache.org
- Published
- 2024-05-02
- Last modified
- 2025-02-13
- Weaknesses
- CWE-444
Affected products
References
- http://www.openwall.com/lists/oss-security/2024/05/02/2
- https://lists.apache.org/thread/ngvgxllw4zn4hgngkqw2o225kf9wotov