CVE-2024-3238
The WordPress Menu Plugin — Superfly Responsive Menu plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 5.0.29. This is due to missing or incorrect nonce validation on the ajax_handle_delete_icons() function. This makes it possible for unauthenticated attackers to delete arbitrary files via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Please not the CSRF was patched in 5.0.28, however, adequate directory traversal protection wasn't introduced until 5.0.30.
- Score
- CVSS 3.1 8.8 High
- Status
- Deferred - security@wordfence.com
- Published
- 2024-08-02
- Last modified
- 2026-04-08
- Weaknesses
- CWE-352
Affected products
- Superfly Responsive Menu (Looks Awesome)
- Wordpress Menu Plugin Superfly Responsive Menu (Looks Awesome)
References
- https://codecanyon.net/item/superfly-responsive-wordpress-menu-plugin/8012790
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3608fce3-0869-4516-ae08-68108f733c37?source=cve