CVE-2024-31867
Improper Input Validation vulnerability in Apache Zeppelin. The attackers can execute malicious queries by setting improper configuration properties to LDAP search filter. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.
- Score
- CVSS 3.1 6.5 Medium
- Status
- Analyzed - security@apache.org
- Published
- 2024-04-09
- Last modified
- 2025-02-13
- Weaknesses
- CWE-20
Affected products
References
- http://www.openwall.com/lists/oss-security/2024/04/09/12
- https://github.com/apache/zeppelin/pull/4714
- https://lists.apache.org/thread/s4scw8bxdhrjs0kg0lhb68xqd8y9lrtf