CVE-2024-31864

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Zeppelin. The attacker can inject sensitive configuration or malicious code when connecting MySQL database via JDBC driver. This issue affects Apache Zeppelin: before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.

Score
CVSS 3.1 9.8 Critical
Status
Modified - security@apache.org
Published
2024-04-09
Last modified
2025-11-04
Weaknesses
CWE-94

Affected products

References