CVE-2024-28746

Apache Airflow, versions 2.8.0 through 2.8.2, has a vulnerability that allows an authenticated user with limited permissions to access resources such as variables, connections, etc from the UI which they do not have permission to access.  Users of Apache Airflow are recommended to upgrade to version 2.8.3 or newer to mitigate the risk associated with this vulnerability

Score
CVSS 3.1 8.1 High
Status
Modified - security@apache.org
Published
2024-03-14
Last modified
2025-03-20
Weaknesses
CWE-281

Affected products

References