CVE-2024-27906

Apache Airflow, versions before 2.8.2, has a vulnerability that allows authenticated users to view DAG code and import errors of DAGs they do not have permission to view through the API and the UI. Users of Apache Airflow are recommended to upgrade to version 2.8.2 or newer to mitigate the risk associated with this vulnerability

Score
CVSS 3.1 5.9 Medium
Status
Modified - security@apache.org
Published
2024-02-29
Last modified
2025-05-06
Weaknesses
CWE-862

Affected products

References