CVE-2024-24778
Improper privilege management in a REST interface allowed registered users to access unauthorized resources if the resource ID was know. This issue affects Apache StreamPipes: through 0.95.1. Users are recommended to upgrade to version 0.97.0 which fixes the issue.
- Score
- CVSS 3.1 6.5 Medium
- Status
- Analyzed - security@apache.org
- Published
- 2025-03-03
- Last modified
- 2025-03-03
- Weaknesses
- CWE-269
Affected products
References
- https://lists.apache.org/thread/j14w6wghlwwrgfgc6hoz9f94fwxtlgzh
- http://www.openwall.com/lists/oss-security/2025/03/03/1