CVE-2024-24772
A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
- Score
- CVSS 3.1 4.3 Medium
- Status
- Modified - security@apache.org
- Published
- 2024-02-28
- Last modified
- 2025-02-12
- Weaknesses
- CWE-89
Affected products
References
- https://lists.apache.org/thread/gfl3ckwy6y9tpz9jmpv62orh2q346sn5
- http://www.openwall.com/lists/oss-security/2024/02/28/5