CVE-2024-10552

The Flexmls® IDX Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘api_key’ and 'api_secret' parameters in all versions up to, and including, 3.14.26 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 3.14.25.

Score
CVSS 3.1 6.4 Medium
Status
Deferred - security@wordfence.com
Published
2025-01-25
Last modified
2026-04-08
Weaknesses
CWE-79

Affected products

References