CVE-2023-43826

Apache Guacamole 1.5.3 and older do not consistently ensure that values received from a VNC server will not result in integer overflow. If a user connects to a malicious or compromised VNC server, specially-crafted data could result in memory corruption, possibly allowing arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.5.4, which fixes this issue.

Score
CVSS 3.1 8.8 High
Status
Modified - security@apache.org
Published
2023-12-19
Last modified
2026-02-25
Weaknesses
CWE-190

Affected products

References