CVE-2023-43643
AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. Prior to version 1.7.4, there is a potential for a mutation XSS (mXSS) vulnerability in AntiSamy caused by flawed parsing of the HTML being sanitized. To be subject to this vulnerability the `preserveComments` directive must be enabled in your policy file and also allow for certain tags at the same time. As a result, certain crafty inputs can result in elements in comment tags being interpreted as executable when using AntiSamy's sanitized output. This issue has been patched in AntiSamy 1.7.4 and later.
- Score
- CVSS 3.1 6.1 Medium
- Status
- Modified - security-advisories@github.com
- Published
- 2023-10-09
- Last modified
- 2024-09-19
- Weaknesses
- CWE-79
Affected products
References
- https://github.com/nahsra/antisamy/releases/tag/v1.7.4
- https://github.com/nahsra/antisamy/security/advisories/GHSA-pcf2-gh6g-h5r2