CVE-2023-42781
Apache Airflow, versions before 2.7.3, has a vulnerability that allows an authorized user who has access to read specific DAGs only, to read information about task instances in other DAGs. This is a different issue than CVE-2023-42663 but leading to similar outcome. Users of Apache Airflow are advised to upgrade to version 2.7.3 or newer to mitigate the risk associated with this vulnerability.
- Score
- CVSS 3.1 6.5 Medium
- Status
- Modified - security@apache.org
- Published
- 2023-11-12
- Last modified
- 2025-02-13
- Weaknesses
- CWE-200
Affected products
References
- http://www.openwall.com/lists/oss-security/2023/11/12/2
- https://github.com/apache/airflow/pull/34939
- https://lists.apache.org/thread/7dnl8nszdxqyns57f3dw0sloy5dfl9o1