CVE-2023-42663

Apache Airflow, versions before 2.7.2, has a vulnerability that allows an authorized user who has access to read specific DAGs only, to read information about task instances in other DAGs. Users of Apache Airflow are advised to upgrade to version 2.7.2 or newer to mitigate the risk associated with this vulnerability.

Score
CVSS 3.1 6.5 Medium
Status
Modified - security@apache.org
Published
2023-10-14
Last modified
2025-02-13
Weaknesses
CWE-200

Affected products

References