CVE-2023-40611

Apache Airflow, versions before 2.7.1, is affected by a vulnerability that allows authenticated and DAG-view authorized Users to modify some DAG run detail values when submitting notes. This could have them alter details such as configuration parameters, start date, etc. Users should upgrade to version 2.7.1 or later which has removed the vulnerability.

Score
CVSS 3.1 4.3 Medium
Status
Modified - security@apache.org
Published
2023-09-12
Last modified
2025-06-25
Weaknesses
CWE-863

Affected products

References